Adsense

Discussion in 'Article Script / Article Directory Script' started by trevorl, Mar 7, 2016.

  1. trevorl

    trevorl New Member

    Hi

    I have a very strange issue.

    On the home page adsense does not show, on every other page it does. However if I append /?index.php to any other string to the home page adsense is fine.

    Any suggestion would be greatly appreciated.
  2. Andrew_G.

    Andrew_G. Staff Member

    Hi @trevorl ,

    System works as expected. As I understood you want to display adsense block on every page of your site except Home.
    When you add index.php to the URL, system displays adsense block due to ../index.php is not a Home page in the Subrion CMS.
    By default, Home page has URL = 'domain.com/' (not /index.php).

    Hope this will help you.

    Please ask in case you have any further questions or problems.
  3. trevorl

    trevorl New Member

    Hi Andrew, Thanks for your reply,

    Sorry for misunderstanding..

    The problem is that the ads will not display on the home page.

    I want them to display on home page. Ads work on every other page apart from the home page.
  4. Andrew_G.

    Andrew_G. Staff Member

    Greetings @trevorl ,

    Most likely, Home page is checked (ticked) as page on which Ads block is not displayed. Please go to Edit Ads block page (Subrion Admin Panel -> Content -> Blocks) and look at 'Visible everywhere' field.

    Please let me know the result.
  5. trevorl

    trevorl New Member

    Hi Andrew, checked this many times, it is on home page, If you use inspector on IE, Chrome or Firefox you can see the code, it just won't display on home page.

    Strange thing;

    http://myste.com = no ads
    http://mysite.com/index. ( with any extension ) = no ads

    but

    http://mysite.com/?index = Ads displayed on home page.
    in fact even http://mysite.com/?anything = ads on home page
    so adding a ? after the / results in ads showing. Obviously this should not be the case.

    Any other page on the site is fine,

    http://mysite.com/members = ads on page

    btw.... I have checked robots and the user agent is allowed for the home page.

    I am thinking it could be something to do with .htaccess ?? You have access to my test site at the moment for another issue.
    Maybe you could take a look?

    Trust me I am not mad :)
  6. Andrew_G.

    Andrew_G. Staff Member

    Hello @trevorl ,

    I've just checked your website ( http://atozarticles.com/ ) and Adsense block is displayed correctly there. I can see it on all the pages (even on Home page). Screenshot attached.

    I.e. I don't see any issue there, please let me know if you have it.

    Attached Files:

  7. trevorl

    trevorl New Member

    Hi Andrew, this has got me stumped..

    I tried on IE, Chrome and windows mobile, also tried on another pc.
    What did you try it on?
  8. Andrew_G.

    Andrew_G. Staff Member

    Hi @trevorl ,

    I tried Chrome :)
    FYI, ads block is displayed on all the pages of your site. Problem is not in the Subrion CMS, it's in the ads code of this block (please try to paste another ads code to this block and problem will disappear).

    Thanks!
  9. trevorl

    trevorl New Member

    Hi Andrew - Something really strange - after one week , all of a sudden it is working on homepage -
    I have done nothing, it just started working , must be an odd Google thing!
  10. Andrew_G.

    Andrew_G. Staff Member

    Nice to see that problem has disappeared, @trevorl .

    Please don't hesitate to contact us if you have any further questions or problems.
  11. trevorl

    trevorl New Member

    cool, thanks for your help. :)
  12. Andrew_G.

    Andrew_G. Staff Member

    We're always at your service, @trevorl !
  13. contacto.bitcard

    contacto.bitcard New Member

    @Andrew_G. @Vasily_B.

    Hello, could you tell me if to add the asynchronous code and the unique number that gives me google adsense to verify my site is realized is this same procedure?
  14. Vasily_B.

    Vasily_B. Project Manager

    Hi @contacto.bitcard

    A late reply, I'm sure :( Anyhow... Yes, you can use the same instructions. If you have a code to be added in header/footer sections of pages, you can always use Miscellaneous section of Configuration and put your code there.
    Please note some servers has strict security permissions and they don't allow Javascript or HTML to be sent via $_POST forms. So in this case the options won't work as the system won't save the changes.

    Cheers

Share This Page