Before Upgrade I need to ask couple questions

Discussion in 'Installation & Upgrades' started by media, Nov 30, 2015.

  1. media

    media New Member

    I have these:
    Subrion CMS v 3.3.5
    Publishing 3.3.0

    So if I update download shows these:
    Subrion CMS v 4.0.1
    Articles Script 1 of 1 domains assigned package / 4.0.0

    Are they compatible???
    Can I start upgrade?
  2. Andrew_G.

    Andrew_G. Staff Member

    Greetings @media ,

    Unfortunately, there is no automatic upgrade patch for the Subrion CMS from 3.3.5 to 4.0.0.

    In order to upgrade your site based on the Subrion CMS of 3.3.5 version and Publishing of 3.3.0 version you need to:
    1) make backup of your site's files and site's DB
    2) install clean 4.0.1 version of the Subrion CMS
    3) migrate all the data from the DataBase of 3.3.5 version to the DataBase of 4.0.1 version by using SQL queries (please don't try to just replace database tables of your new version with database tables of your old version, it will cause many errors and your site will not work correctly).
    4) if you want to use the template that you're using on 3.3.5 version and we don't have it for 4.0.1 version , then template upgrade process will cost $80. You can also use one of our free available templates compatible with 4.0 version from here: http://www.subrion.org/templates/

    Also we can upgrade your site to the latest version. It will be a paid service. If you are interested in this service please submit the ticket in our HelpDesk system -> Installations / Upgrades / Migrations dept.

    Thanks for choosing our software products!
  3. media

    media New Member

    Again, there is NO upgrade script....
    Wow man, you guys are trying to get rid of US or what.

    Are you going to give us those Sql codes that we can migrate????

    I am not sure why you do not create a upgrade script????? No idea

    I am in web business almost 20 years. I have vbulletin, ipboard, phpmydirectory, xzero script, Dzoic, sosovien, qa and so on 20 more script. NONE of these companies release a new version (increment the version number by 1) and left their customer without a upgrade script NOR they ask MONEY to upgrade....I only pay their yearly script FEE and always they provide upgrade script and support that script....

    Good job guys....!!!!!!!!!!!!!!!!!!
    Last edited: Dec 1, 2015
  4. Vasily_B.

    Vasily_B. Project Manager

    Hi @media,

    Thanks for your post. At the moment, there is no auto updater tool. The new version is a major update, that has incompatible structure of extensions and templates.
    Anyhow, 3.3.5 is a long-term-support version and you can go on using it.

    Cheers
  5. media

    media New Member

    So you are basically saying that we are Doomed.

    :(

Share This Page