Can not upload large files, session timout, general question not Subrion.

Discussion in 'General Chat' started by projectashenfire, Oct 5, 2017.

  1. Even though this site seems dead, I was hoping maybe I could get general advice not related to Subrion.

    I have asked my hosting provider for help (most of them don't deserve to work there). I have two problems.
    1. I had a problem with my site logging me out, which I had fixed with the help of 3 site designers.
    After I asked my webhosting provider for help (problem #2) they broke my resolution trying to fix
    probem #2. I am being logged out before 1 hour passes.

    2. I want to upload 1Gb files ( so far thats all I need). I don't have any .php file that controls the upload size.
    I used php.ini on all of my domain entry points (projectashenfire.org / gallery304.projectashenfire.org; etc.

    There are no controlling files. I am only supposed to change mysql php settings. It is not working.
    I was getting an AJAX error so I installed ajax and related material but it now I get an ajax controller error.
    Old ajax error:
    • AJAX: error 0 (rejected) for URL: tiki-ajax_services.php?controller=file&action=upload_multiple
    new error
    internal server error
    After installing
    I need to know what is involved to make files that are large in size, get uploaded to my site. I can FTP large
    files, I just cant use a web page of mine.

    These are my settings for now.

    upload_max_filesize = 1000M
    post_max_size = 1000M
    memory_limit = 1000M
    max_execution_time = 90
    max_input_time = 90
    file_uploads = On
    Last edited: Oct 6, 2017
  2. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    It's not dead. We process a lot of subrion related requests via Helpdesk system as most of the questions are rather specific and require personal private details.

    Regarding the task. Just perform a basic test that would allow to upload a file without any CMS or anything like that. Without sessions, etc. In this case you will understand if your server allows to do that and it's not related to other stuff.
    Here is the basic file that would allow to check it:
    https://gist.github.com/taterbase/2688850

    If the file is uploaded (as a site note - I'd increase values from 1000M to 2000M just for tests, as 1Gb stands for 1024Mb), then it's related to a session setting on your website.

    Good luck!
  3. Ok, thought it was dead because my post for upgrading Subrion Navi Pres to latest version wasn't answered. It has been a year.

    Anyways I created the upload.php file and it successfully transferred my 575Mb file to the server.

    Before I posted here, I originally put 1000000000 (no letters),then later 1000M in my php.ini file but no success.
    I already had a problem with session.gc_maxlifetime not working even though I changed it, which could suggest my changing upload_max_filesize is not being recognized either.

    So my question is what session setting is related to the upload?
  4. CKENT

    CKENT New Member

    To answer your question, all of them are related to the upload.

    • upload_max_filesize = The maximum size of an uploaded file.
    • post_max_size = Sets max size of post data allowed. This setting also affects file upload. To upload large files, this value must be larger than upload_max_filesize. Generally speaking, memory_limit should be larger than post_max_size. When an integer is used, the value is measured in bytes. Keep in mind your post max size also includes the size of the information to post.
    • memory_limit = This sets the maximum amount of memory in bytes that a script is allowed to allocate. This helps prevent poorly written scripts for eating up all available memory on a server.
    • max_execution_time = This sets the maximum time in seconds a script is allowed to run before it is terminated by the parser. This helps prevent poorly written scripts from tying up the server.
    • max_input_time = This sets the maximum time in seconds a script is allowed to parse input data, like POST and GET. Timing begins at the moment PHP is invoked at the server and ends when execution begins.
    • ON BOTH MAX TIMES - ON SHARED SERVERS YOU MAY NEED TO INCREASE DUE TO SLOWER PROCESSING, RAM AND SERVER BANDWIDTH
    • file_uploads = Whether or not to allow HTTP file uploads. See also the upload_max_filesize, upload_tmp_dir, and post_max_size directives
    Technically you need to raise your memory limit above max_post and max_post above your upload_max for ideal conditions, though it should work as is. A lot of hosts especially those on shared hosting plans will limit your access to changing any php directives. Some will also set absolute max sizes and times so that even setting php.ini or in htaccess will not go above their max levels. Which hosting provider are you using? You may need to look at their knowledge base or support articles in order to find out what they limit and their recommended settings, as well as how to change them.
  5. I know what they mean. I also can read the PHP comments next to each setting in the php help windows. I was informed by reading, that post_max_size is supposed to be larger than upload_max_filesize, I had my post at 2Gb and my upload size at 1gb. The technicians on my site changed it so many times, as if it DIDN"T matter.


    I had it set to unlimited memory before they changed it, but I was getting a file upload error using a file manager. Without the file manager, no issues arise.



    I already have read their worthless FAQ and I have been working with them for a week. I need outside suggestions, because my support says they are not limiting me in any way.
    I just got them to finally realize their symbolic link for PHP was broken ( it wasn't using the PHP.INI file they swore I had to use).

    Now, I get internal error message.
    Hosting site is webhostingpad.com
    Last edited: Oct 11, 2017

Share This Page