Database Error Using Portfolio

Discussion in 'Subrion CMS Plugins Discussion' started by projectashenfire, Jan 8, 2016.

  1. I was expanding my knowledge on what else this CMS can do for me and I tried my luck with
    the content/portfolio option. It was bad luck.

    I added text to the text field, added a 1024x768 picture. I got a database error and a blank screen.
    I tried again with a 250X250 picture and got the same problem.

    What server side protocols do I need to verify are active, to make this work?
    The last time I got this error you guys recommended I turn a feature off, on the server & it
    resolved my issue. I hoping this might be true again.
  2. Andrew_G.

    Andrew_G. Staff Member

    Greetings @projectashenfire ,

    Portfolio plugin of 4.0.0 version works fine on Subrion CMS of 4.0 version. We've checked this plugin on our local and real servers and there are no any error (even warning).

    Most likely, you're getting a blank screen due to the small value of the 'memory_limit' config on your server. It should be at least 128M (256M and higher recommended).

    If this will not help you please submit a ticket in our HelpDesk system (including your FTP details) and me or my colleagues will investigate the issue directly on your site asap.

    Thanks for choosing our software products!
  3. I guess others have access to 'memory_limit'. I apparently don't see any option in Cpanel that allows me check. Where is it?
    I have 1024M Virtual memory on my cpanel but no option to check any further.

    I did get an actual database error which is my main concern, I have a feeling that fixing this will fix any other 'complication error' such as my screen sometimes
    being blank when attempting to recreate the issue.

    Attached Files:

    • 0002.jpg
      0002.jpg
      File size:
      142.2 KB
      Views:
      13
    Last edited: Jan 10, 2016
  4. Andrew_G.

    Andrew_G. Staff Member

    Hello @projectashenfire ,

    It's really difficult to determine the reason of your problem without having access to your site.

    Please submit a ticket in our HelpDesk system (including your FTP details) and me or my colleagues will investigate the issue directly on your site asap.

    Thanks!
  5. I agree with you, but I was still wondering where to find the settings. I don't have php.ini in my cpanel. I accidently found the setting under CHANGE PHP version. It was on 128M. I changed it to 256M.

    I am putting out another 'fire' right now; so I will submit a ticket later if I can.
  6. Andrew_G.

    Andrew_G. Staff Member

    Hi @projectashenfire ,
    If your 'memory_limit' is equal to 256M now then reason of this issue is not in 'memory_limit'.

    Please enable the Debug mode (instruction: http://dev.subrion.org/projects/subrion-cms/wiki/DebugMode ) then try to add Portfolio entry. You'll get database error message (as you noted before), please click on the red square Debug at the bottom right, then copy and send me or paste here the content of Debug window.
  7. Sorry it took this long to reply. I am overwhelmed with all the tasks that I have here. I am assuming you want me
    to do the 'user' debug instead of the 'global' debug?
  8. This time I was not going to re install my CMS, but I am lucky that I had no portfolios before this error, so I just uninstalled/re installed the plugin.
    It works now.
    I did not figure out where I was supposed to enter 'PORTFOLIO'. So for future reference, it should be noted HOW to use the debug instruction.
    You showed me a new trick that will help me troubleshoot in the future and I would still love to know how to use the db query properly.

Share This Page