Error installation subrion

Discussion in 'Installation & Upgrades' started by gioalba1, Feb 20, 2015.

  1. gioalba1

    gioalba1 New Member

    I am trying to install the free csm subrion.
    I have this error:
    I apache listening on port 8080.
    I enter http: // localhost: 8080 / subrion / install /
    I get the welcome page subrion CMS 3.2.7 and installation wizard.
    Pressing on installation wizard get redirected on
    http: // localhost / subrion / install / install /
    that does not exist.
    how do I fix?
  2. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    Thanks for your interest in our software. Please make sure mod_rewrite is enabled on your server.
    That seems to be the cause of the issue.
  3. gioalba1

    gioalba1 New Member

    thanks response.
    in the apache config
    Rewrite_module LoadModule modules / mod_rewrite.so
    is Uncomment
  4. Vasily_B.

    Vasily_B. Project Manager

    Make sure allowoverride all is enabled on the server:
    http://stackoverflow.com/questions/869092/how-to-enable-mod-rewrite-for-apache-2-2

    You may perform the basic tests to make sure mod_rewrite really works as expected. We don't have install/ folder in install, but the url you posted is correct. So the issue is related to redirection, and it's either lack of mod_rewrite, or you somehow don't have .htaccess in both subrion root and install/ folders.

    Let us know the results please.
  5. gioalba1

    gioalba1 New Member

    AllowOverride All solved by adding and putting apache on port 80.
  6. Vasily_B.

    Vasily_B. Project Manager

    Ok, it's great you solved this finally. Anyhow, it's more related to the LAMP server setup, rather than cms functionality. Anyway, I was happy to provide you with the possible solution.
  7. florian.dammeyer

    florian.dammeyer New Member

    I ran into the same problem right now and I don't think it has to do with my server configuration.

    In our corporation we have set up a standardized Vagrant dev environment running a LAMP stack for our Zend Framework 2 apps, and now I was testing some CMS's inside that same Vagrant environment to find the best one for a new project. My local port 8080 (http://localhost:8080/) redirects to port 80 on the virtual machine, so I can access the virtual web server as if it was running on my local computer.

    Zend Framework 2 apps, concrete5, contao and wordpress all run without problem. The subrion installer however discards the port when redirecting to the next step and also when retrieving JavaScript files etc., so that the first step of the installation process already looks ugly because all CSS files are missing and clicking on "Next" gives me a "Page not found" error because subrion is redirecting to http://localhost/ instead of http://localhost:8080/.

    Is my feeling right that this is a bug?
  8. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    Thanks for the report @florian.dammeyer and welcome aboard. Please allow us few hours to check installation on port based URL so I could get back to you with the solution. It's kinda late here now, just 8 minutes past midnight. My colleagues from tech dept will take care of this issue in the morning and post the solution here.

    Thanks!
  9. Vasily_B.

    Vasily_B. Project Manager

    Hey guys,

    Here is the quick solution for now:
    Edit install/index.php and find this line:
    PHP:

    define('URL_HOME', 'http://' . $_SERVER['SERVER_NAME'] . IA_URL_DELIMITER . $scriptFolder);
     
    change it to the following lines:
    PHP:

    $scriptPort = (80 == $_SERVER['SERVER_PORT']) ? '' : ':' . $_SERVER['SERVER_PORT'];
    define('URL_HOME', 'http://' . $_SERVER['SERVER_NAME'] . $scriptPort . IA_URL_DELIMITER . $scriptFolder);
     
    it should allow you to perform the installation correctly. Let us know the results please.
  10. florian.dammeyer

    florian.dammeyer New Member

    That did the trick, installation went perfectly and the system runs without problem so far. You should consider including that fix in an upcoming release ;)
  11. Vasily_B.

    Vasily_B. Project Manager

    Thanks for your report.
    Sure, we will definitely do this. Now in the process of finding improvements for this.

    Don't hesitate to ask if you have any questions.

    Cheers
  12. gioalba1

    gioalba1 New Member

    Hello,
    I do not know if it's my problem. Once installed subrion on a port other than 80, the installation, also the version 3.3.3, goes perfectly.
    The problem is the next operation. Just installed everything ok. And Then:
    1) Gate cache
    2) I try to log in again and the system tells me: "
    Error 403
    Action is forbidden."
    3) From the administration panel when accessed chase me out.
    regards
    Last edited: Mar 25, 2015
  13. Vasily_B.

    Vasily_B. Project Manager

    What happens if you try to login using front end? Do you still have the software installed on the port, other than 80? Please clarify.

    We have your details, so we will check the issue directly on the server. Thanks!
  14. gioalba1

    gioalba1 New Member

    Hello,
    Yesterday I had thought to have solved. I had installed Subrion on the same port of another software.
    Today, however, the problem is new.
    On port 4529 is only subrion.

    If I login from the front end tells me:
    Error 403
    Action is forbidden."
    If I access the administration panel, he show me only the pages, without the information from db. If I press on any field panel chase me out.
    thank you
  15. sumedh.dshmkh

    sumedh.dshmkh New Member

    I am trying to install the free csm subrion.
    One of the errors I am having is same as giolba1 had
    config page is going to install/install directory,but working
    problem is after i enter all config and press install
    i get a error message like the image i posted
    i have enabled mod_rewrite and AllowOverwrite All as also the change Vasily posted in install/index.php
    also i have tried installing with installtron but i get this error:
    FileSystem::mkdir(ftps://admin:[email protected]:80) - code: mkdir($path, 493);
    FileSystem::mkdir(ftps://admin:[email protected]:80/http:) - code: mkdir($path, 493);
    FileSystem::mkdir(ftps://admin:[email protected]:80/http:/localhost) - code: mkdir($path, 493);

    Attached Files:

    Last edited: Mar 30, 2015
  16. Vasily_B.

    Vasily_B. Project Manager

    Hi @gioalba1,

    Did you change the port after installation? If so you'd need update your config table and set a new URL for your subrion port installation.

    Guys,
    Sorry, it's not easy to reproduce all these local issues without access to your server, and the config we generally use for all the hosting companies usually works fine. A dozen of incorrect things might cause the issues you have, and we don't have a universal solution for WAMP servers :( Sorry, there are too many configs. I've tested installation on different ports and and it worked fine so I don't have a clue what could be wrong.

    @sumedh.dshmkh Sorry, no guess what could be wrong. Try to disable Just-in-time debugging, not sure though.

    Cheers
  17. gioalba1

    gioalba1 New Member

    Hi,
    the strange thing I notice is this:
    after installation subrion works. The problem appears when i empty the browser cache.
    you have the data to do a check on my server ;)
  18. qt4004

    qt4004 New Member

    Hi Vasily

    I enter http: // localhost / subrion / install /
    I can not get the welcome page and installation wizard.
    I only get index of the files. Then, I enter install.php and show Internal Server Error.

    How can I fix it and get the installation wizard? Thanks!

    Teddy
    Last edited: Jun 23, 2017
  19. Dayir_A.

    Dayir_A. Staff Member

Share This Page