Form to add parts, does not show captcha to unregistered user.

Discussion in 'Auto Classifieds Script' started by olairmarcos, Mar 11, 2016.

  1. olairmarcos

    olairmarcos Member

    Form to add parts, does not show captcha to unregistered user.

    ____ According to my settings in the setup package file, the unregistered user can register parts in auto Parts.
    2016-03-11_101710.jpg

    ____ When you save the record, I have an error message. Price is empty and Code incorrect.
    You can not enter data (numbers) in the field PRICE.
    2016-03-11_113836.jpg

    The form is not shown the captcha image and can not enter the code to save the form.

    Thanks for help.
  2. Vasily_B.

    Vasily_B. Project Manager

    Please use the same changes as we reported in your previous services report.

    Code (Text):

    {ia_hooker name='smartyListingSubmitBeforeFooter'}

    {include file='captcha.tpl'}
     
    ^ code should be placed in {capture append='tabs_after' name='__all__'} capture block.

    Price worked fine well, it does not allow to input letters only. Digits are available. Make sure via phpMyAdmin that your price field 'length' column is not equal to 0.

    Thanks again for your reports.
  3. olairmarcos

    olairmarcos Member

    In Parts I do not have the error wrong captcha code, apparently works correctly. The problem now is not being able to type numbers in the price field.
  4. olairmarcos

    olairmarcos Member

    We also found that you can not enter any value (numbers) in this field. To add funds for the administrator account.

    2016-03-16_154144.jpg
  5. Vasily_B.

    Vasily_B. Project Manager

    Parts captcha also has the same issue as the services page. Anyhow, it's not obvious now as it only has one field group.

    It looks like you have an issue with JS library, that blocks non digits input. Could you please check your browser console for JS errors? Default installation works fine for us in both demo version & local git version in several browsers.
    What browser do you use?

    Thanks!

    P.S. Please use the updated version we will release in a couple of minutes.
  6. olairmarcos

    olairmarcos Member

    Well, we found that the value to add in the field did not appear because the size of the box is too small. The solution was to reduce the sentence (Amount to add) to (Amount) thus opens a larger space for the characters (numbers) can be viewed when they are entered in the field. See the image below.

    2016-03-22_102937.jpg
    Dayir_A. likes this.
  7. olairmarcos

    olairmarcos Member

    We investigate in detail about the work not correct the price field in Autos parts.

    We found that when the Autos package is installed, the system installs the price field with a length of the field (0), can not enter characters (numbers) in the price field.

    2016-03-23_104920.jpg

    When we set the field to (not required) the system saves the field length (8) and works properly.

    2016-03-23_105255.jpg

    2016-03-23_105331.jpg

    Again changed the price to field (required) and the system now correctly saved with the length (8) and continues to work properly.

    2016-03-23_113652.jpg

    End of problem. Good job. I eat an X-burger.:)
  8. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    Cool you've sorted out this.

    Please check my original reply:
    I guess I was not descriptive enough here.
  9. Dayir_A.

    Dayir_A. Staff Member

Share This Page