Resolved Fresh new install (installer is not accessible)

Discussion in 'Installation & Upgrades' started by nikovic, Feb 25, 2014.

  1. nikovic

    nikovic New Member

    Hi,

    Trying your demo I found your product well designed and wanted to test it.
    I extracted the zip in my /var/www/ but when I when to access to localhost/subrion, I am immediatly redirected to localhost/subrion/install/install (which of course doesn't exsit).

    Do I have to modify the .htaccess in subrion/install or is the issue something else?

    Thank you for you time and answer :)
  2. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    This seems to be a common problem related to .htaccess. It strongly depends on server configuration and in some cases it does not work as expected from the box.

    Possible ways to resolve the issue:
    1. Make sure your Apache mod_rewrite is enabled
    2. Make sure you do have .htaccess in your script root folder
    3. Make sure you do have .htaccess in your script install/ folder

    Sometimes another Apache directive can resolve the issue - that's RewriteBase

    Open your script root folder .htaccess file and find the commented RewriteBase and set it to RewriteBase /subrion - uncomment it. Try again!

    This should resolve your problem. You should be redirected to localhost/subrion/install/install/ and you should see subrion installer page.
  3. nikovic

    nikovic New Member

    Dear Vasily,

    Thank you for your helpful answer. The cause was indeed related to the apache mod_rewrite. As I forgot to edit /etc/apache2/sites-available/default to replace AllowOverride None by AllowOverride all.

    The installer now appears :).
  4. Vasily_B.

    Vasily_B. Project Manager

    I'm happy to advise.
  5. fpoveda

    fpoveda New Member

    I'm really sorry but I'm using MAMP, and I can't see that file or where change it. Appreciate your answer.
  6. Vasily_B.

    Vasily_B. Project Manager

    Welcome aboard, @fpoveda

    According to MAMP configuration manual you can find your Apache config file here:
    Applications:MAMP:conf:apache:httpd.conf
    If it's not there, please search the system for httpd.conf - that's Apache server config - and enable mod_rewrite module in it.

    Do you have the same issue like described above? AFAIK MAMP goes with mod_rewrite module enabled by default.

    Thanks!
    fpoveda likes this.
  7. shekhar

    shekhar New Member

    I am geting this error
    Kindly Help

    I am using
    IIS7

    upload_2015-5-20_17-15-36.png
  8. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    Unfortunately we cannot help as the system only supports IIS web server with ISAPIRewrite 3 enabled .

    Cheers
  9. jacobford

    jacobford New Member

    Hello,

    Thanks for already posting this thread. I thought it was a bug with the CMS but then I realised my FTP software doesn't show hidden files by default.

    Uploading the two .htaccess fixed the issue, cheers.

    JF
    Vasily_B. likes this.
  10. Vasily_B.

    Vasily_B. Project Manager

    Hi

    yep, .htaccess is hidden on some systems so mod_rewrite does not work correctly. The system does not understand redirection in this case.
    Great, you've managed to solve this yourself, Jacob. Don't hesitate to ask if you have any questions.

    Cheers

Share This Page