Listing Details Error after HTTPS set up. (cant access details)

Discussion in 'Subrion Open Source CMS Core' started by willylions, Jun 7, 2017.

  1. willylions

    willylions New Member

    Hi there. i recently set up the SSL certificate and activated the HTTPS on the cpanel System Set up for our site Garaje.do. After setting it up i'm unable to view any listing details, when i click on any listing item i get redirected to homepage, guessing beacause it gives an 404 error it gets redirected to homepage.

    I've clear the cache from the cpanel, erased the tmp folder content, and clear the cache from my borwser too.
    All pages works fine and all items are correctly listed. Cant access any ITEM details page.

    Anyone, help?
  2. Dayir_A.

    Dayir_A. Staff Member

    Hello @willylions,

    You did everything correctly. Only 1 thing left:

    Please change value of `baseurl` config's value to httpS value. To do so you may run this query:
    Code (Text):

    update {prefix}config set `value` = 'https://yourdomain.com/' where `name` like 'baseurl';
     
    Make sure to replace {prefix} with actual prefix (can be found in /includes/config.inc.php file INTELLI_DBPREFIX constant's value)
    and 'yourdomain.com' with your domain name (trailing slash cannot be omitted)

    Also you may wish to have users automatically redirected from http to https when accessing your website.
    To do so you should uncomment or add if not presented these lines in your .htaccess file. To uncomment just remove # from each line
    Code (Text):

    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
     
    Thanks.
  3. willylions

    willylions New Member

    Hi there, so much grateful for this. now it works. i didn't had to update the databas since it auto change the baseurl when i set it on system settings.
    The thing i was missing was in the htaccess file. but i didn't had to add any code just added the S in HTTP on this code:

    Code (Text):

    RewriteCond %{REQUEST_URI} !(.*)\.(.*)$
     RewriteRule ^(.+[^/])$ https://%{HTTP_HOST}%{REQUEST_URI}/ [L,R=301]
     
    that worked, thanks a lot
    Dayir_A. likes this.

Share This Page