Localhost Server

Discussion in 'General Chat' started by Greg, Jan 18, 2013.

  1. Greg

    Greg Super Moderator

    What localhost server do you recommend?

    I'm currently using:
    WAMP Version 1.7.2

    This is for Windows 7.
  2. wazza

    wazza Member

    Have you looked at wamp server?

    Easy straight forward install of everything you need.

    Just need to enable mod rewrite and your away.

    Regards,
    Quentin
    Last edited: Jan 18, 2013
  3. Vasily_B.

    Vasily_B. Project Manager

    Hi Greg,

    That's my windows configuration:
    It works fine for me. Some other guys here have openserver:
    Open Server - WAMP . , -, wamp localhost.

    Not sure if they have English version. Anyway, my vote goes for xampp as it's simple and easy to use!
  4. Greg

    Greg Super Moderator

    Thanks guys

    @wazza - I am using WAMP Version 1.7.2

    Think I'll give XAMPP Version: 1.7.4 a try.
  5. Greg

    Greg Super Moderator

    What version # are you using?
  6. wazza

    wazza Member

    I use 2.2.
  7. Greg

    Greg Super Moderator

    Thanks wazza
  8. Vasily_B.

    Vasily_B. Project Manager

    Hi guys,

    Now getting more information about Vagrant servers. It seems to be a nice thing, that's quite easy to use. I'll post more details later about it.

    Thanks!
  9. Greg

    Greg Super Moderator

    Trying to catch up on some stuff that I had on my now dead laptop.
    My new system has Windows 8 - 64 bit.
    I like wamp so I'd like to stick with that. But I don't really know which one of these I should install? There are 3 to choose from.
    http://www.wampserver.com/en/download-wampserver-64bits/

    Thanks
  10. Gleb_S.

    Gleb_S. Subrion Designer Staff Member

    Hello, @Greg!
    I'm using 2.4 version (64 bits & PHP 5.4) on my Windows machine. No problems have encountered so far.
  11. Vasily_B.

    Vasily_B. Project Manager

  12. Greg

    Greg Super Moderator

    Thanks guys. But I'm not having much luck.

    For wamp after clicking on the link to download @
    http://www.wampserver.com/en/download-wampserver-64bits/

    I get a popup box saying: (with a link)
    WARNING : You must install Visual C++ 2010 SP1 Redistributable Package x86 or x64
    [​IMG]


    For Open Server - When I click on the download button it takes me to another page to do something, I guess. But I don't know what it is as I don't know the language.

    o_O
  13. Gleb_S.

    Gleb_S. Subrion Designer Staff Member

    Hello Greg,
    I just ignored the warning because I had the Visual C++ Package installed. Probably, you have it installed as well.
    If no, then just download the package vcredist_x64 and install it.
  14. Greg

    Greg Super Moderator

    Thanks Alex

    I'll just ignore it and give it a try. Just don't want to mess up my new laptop.
  15. Greg

    Greg Super Moderator

    I got it up and running. Thanks again :)
  16. Vasily_B.

    Vasily_B. Project Manager

    Nice, don't forget to enable that mod_rewrite module. I don't remember if that module is enabled in WAMP by default, though it was definitely OFF in my XAMPP default installation o_O
  17. Greg

    Greg Super Moderator

    Thanks for the reminder. Done :)
  18. Well, I missed having a website, so after creating an automation process for batch files and modding, I installed WAMP.

    I did not see the mod_rewrite module in my apache module list. The others seem to work.

    UPDATE: found, rewrite_module. Appears to be already checked on install.

    Also, why is it that all services are running green, however I tried installing Subrion 3.3.5 from c:/wamp64/www/install and the install menu says MySQL is NOT running?

    I am fairly certain it is running.

    UPDATE: talking to myself on this dead site. I still will be informative to any person who has this problem.
    After placing mySQL back to version 5.7.19
    and placeing PHP back to 5.6.31; it installed with errors, missing tables, it would only install 33 out of 60+ tables.

    After many attempts, it installed all tables.


    I have already created a DB for it via ADMINER. I have added username/pwd to the DB and I have imported my original backup into PHPADMIN
    and all that is left is install.


    Subrion ERROR Received:

    Server Configuration
    Mysql version Required MySQL 5.x or upper required
    PHP version Required 7.1.9
    Remote files access support Available
    XML support Available
    MySQL support Unavailable (required)
    GD extension Available
    Mbstring extension Availabl








    What I am running from localhost.
    • Version 3.1.0 - 64bit

      • Server Configuration
        Apache Version:
        2.4.27 - Documentation
        PHP Version:
        7.1.9 - Documentation
        Server Software:
        Apache/2.4.27 (Win64) PHP/7.1.9 - Port defined for Apache: 80
        Loaded Extensions :
        • apache2handler
        • bcmath
        • bz2
        • calendar
        • com_dotnet
        • Core
        • ctype
        • curl
        • date
        • dom
        • exif
        • fileinfo
        • filter
        • gd
        • gettext
        • gmp
        • hash
        • iconv
        • imap
        • intl
        • json
        • ldap
        • libxml
        • mbstring
        • mcrypt
        • mysqli
        • mysqlnd
        • openssl
        • pcre
        • PDO
        • pdo_mysql
        • pdo_sqlite
        • Phar
        • readline
        • Reflection
        • session
        • SimpleXML
        • soap
        • sockets
        • SPL
        • sqlite3
        • standard
        • tokenizer
        • wddx
        • xml
        • xmlreader
        • xmlrpc
        • xmlwriter
        • xsl
        • Zend OPcache
        • zip
        • zlib
        MySQL Version:
        5.7.19 - Port defined for MySQL: 3306 - Documentation
        MariaDB Version:
        10.2.8 - Port defined for MariaDB: 3307 - Documentation
    Last edited: Feb 18, 2019

Share This Page