Meet my new Youtube Gallery Plugin!

Discussion in 'Subrion CMS Plugins Discussion' started by david_munroe, Feb 23, 2015.

  1. david_munroe

    david_munroe New Member

    wazza, ganodan and Vasily_B. like this.
  2. Vasily_B.

    Vasily_B. Project Manager

    Thanks David. Yet another reason for us to improve items functionality, so comments/reviews/etc. could be linked with the content created by plugins, not package items only. Good luck with the extension.
  3. ganodan

    ganodan New Member

    Hey david_munroe,

    Thanks, this is a much needed plugin, I have purchased and installed.

    2 problems I see straight of the top are, it's not responsive, and there should not be suggested videos when the video finishes to allow taking site visitors from the site to YouTube, sort of defects the purpose of trying to keep visitors on site.

    Cheers,
    Dan.
    Last edited: Feb 24, 2015
    david_munroe likes this.
  4. david_munroe

    david_munroe New Member

    Hi @ganodan ,

    Thank you for purchasing. I'll take care of these problems. Give me a couple of days :)
    Vasily_B. and ganodan like this.
  5. david_munroe

    david_munroe New Member

    Hi @ganodan,

    To disable relative videos you should add rel=0 to youtube's url in youtube_gallery/templates/front/intex.tpl
    Find in .tpl this code
    Code (Text):
    <div class="ycontent">
            <iframe width="{$width}" height="{$height}" src="//www.youtube.com/embed/{$video.video_id}?showinfo=0&#038;iv_load_policy=3&#038;vq=large&#038;modestbranding=1&#038;theme=light" frameborder="0" allowfullscreen></iframe>
    </div>
    and add rel=0 like this src="//www.youtube.com/embed/{$video.video_id}?showinfo=0&#038;iv_load_policy=3&#038;vq=large&#038;modestbranding=1&#038;theme=light&#038;rel=0"

    To make youtube video responsive add this code to youtube_gallery/templates/front/css/style.css

    Code (Text):
    .
    ycontent {
        position: relative;
        padding-bottom: 56.25%;
        padding-top: 30px; height: 0; overflow: hidden;
    }

    .ycontent iframe,
    .ycontent object,
    .ycontent embed {
        position: absolute;
        top: 0;
        left: 0;
        width: 100%;
        height: 100%;
    }
    I will release the new version with this bugfixes on this week.
    ganodan likes this.
  6. ganodan

    ganodan New Member

    Thanks david_munroe,

    Works for me :)

    I also found the gallery category name does not show in the URL, only the ID number, videogallery/1-Title-of-Video.html

    The category name shows in the menu OK, "Home / Video Gallery / Cat Name /" however the URL for "Cat Name" shows as videogallery/?cat_id=1

    Dan.
    david_munroe likes this.
  7. david_munroe

    david_munroe New Member

    Hi @ganodan ,

    The new version almost ready. I will release this week with bugfixes and more options. :)
    Last edited: Feb 25, 2015
    Gleb_S. and ganodan like this.
  8. ganodan

    ganodan New Member

    Hi david_munroe,

    Just curious, would "Sub Categories" be one of the more options?
  9. ganodan

    ganodan New Member

    david_munroe,

    I have use this plugin and have seen top page 1 rankings in Google over other pages on my site.

    Look's like it's true what they say about video taking over in search.

    Dan
    Last edited: Mar 2, 2015
  10. ganodan

    ganodan New Member

    Just to add to above.

    Mobile has over taken desktop according to a report on Facebook ads. I think the fact that your video plugin is fully responsive also helps in page rankings.
  11. david_munroe

    david_munroe New Member

    Hi @ganodan ,

    Glad to hear it.
    Sorry I was off sick for a while. I will release the plugin this week.
    It will take me a lot of time to implement this feature. I did not plan to make it.
  12. ganodan

    ganodan New Member

  13. ganodan

    ganodan New Member

  14. david_munroe

    david_munroe New Member

    Hi @ganodan ,

    I have just uploaded the new version with bugfixes and more options...
    Also fixed this
  15. ganodan

    ganodan New Member

    Hi.

    Upgraded, all videos are returning 404
    Category URL's are stills showing as videogallery/?cat_id=1 etc. With all video's being added to all categories
    videos from Categories have 2 forward slashes in the URL... videogallery//1-video-title.html

  16. ganodan

    ganodan New Member

    I have uninstalled plugin.
  17. david_munroe

    david_munroe New Member

    Hi @ganodan ,

    I installed the new copy of Subrion, downloaded the plugin v 1.0.1 from Subrion.org and tested it. It works fine. No 404 errors.

    I've added category's alias to url like videogallery/category-alias/1-video-title.html


    [​IMG]
  18. ganodan

    ganodan New Member

    I think it maybe be for 3.3.0 as you said you installed a new copy of Subrion.

    My bad, I tried upgrading my current site 3.2.7.

    It will be a long time before I can upgrade my site to 3.3.0 as I have to wait until for all the packages & plugins to be upgraded to 3.3.0 and going by the last version upgrade that will be quite some time away.

    Cheers,
    Dan
  19. ganodan

    ganodan New Member

    Hi david_munroe,

    I tested on a new install of 3.3.0 using Schedar Template

    The video URL is working, however you need to look at Video Blocks, category is not included, returns 404
    All Video's are added to all Categories, regardless of what category the video is assigned to.
    Video Category Name (Block) not included in URL, Only videogallery/?cat_id=1 - videogallery/?cat_id=2 - videogallery/?cat_id=3 etc.

    Dan
  20. wazza

    wazza Member

    Totally agree Vasily!

Share This Page