Subrion CMS 2.3.3 Released!

Discussion in 'Announcements' started by Vasily B., Jan 25, 2013.

  1. Vasily_B.

    Vasily_B. Project Manager

    Greetings,

    Meet the new minor patch for the Subrion cms - 2.3.3

    It does not have new features, just some minor fixes. Here is the changelog:
    See the detailed description here.

    Generally this patch is intended to see how the upgrade system works! In order to apply it please follow the instructions below:

    1. Make backups of your files + database
    2. Download the file attached in this post, unpack it and upload the contents to install/classes/folder of your current 2.3.2 installation
    3. Then go to admin panel of your website. You will see a notice there to upgrade your version.
    4. Click it, you are redirected to the upgrade process
    5. Follow the upgrade instructions

    Please BE PATIENT once you click Next - the upgrader will download 1mb file from the server so it can take some time.

    It's important to keep your log file. The upgrade will reupload all the files that were not modified on your server. If they are modified you'll see that in report. You will need to reupload them manually!

    If you see the following errors, please ignore them as the folders are actually deleted:
    Please be careful! Contact us if you have any questions!

    Attached Files:

  2. smartpc

    smartpc New Member

    Ah got it login to admin panel ;), upgrade seemed to go fine, got this error on legend:

    ERROR The checksum is not equal — file md5() hash checksum does not match the default one that comes with Subrion software. It's possible this file was modified on your server.

    Oh probably left out the WOW like it...ah and it leaves the modified files alone very nice.

    Where did the 1mb file download too?
    Last edited: Jan 25, 2013
  3. Vasily_B.

    Vasily_B. Project Manager

    Hi

    You can download the core version from our website and manually verify the file(s) that was/were not uploaded. It does not replace the files that were modified.

    By default upgrade unpacks to tmp/ folder. But it's in its own format.

    P.S. there are still some features to be added to upgrade - diff viewer, files backup, etc. Anyway, they will be implemented in the next version.
  4. smartpc

    smartpc New Member

    Yes I see it now, I uploaded datepicker change files the other day for a plugin problem on 2.3.2 install

    this is one of them
    ERROR: Unable to remove the directory: js/jquery/plugins/datepicker (seems modified).

    Uploaded before upgrade:
    ERROR: The checksum is not equal: install/classes/ia.patch.applier.php (seems modified).
    ERROR: The checksum is not equal: install/classes/ia.patch.parser.php (seems modified).

    the one you were talking about:
    ERROR: Unable to remove the directory: includes/asido

    and this, dont recall going near this:
    ERROR: The checksum is not equal: includes/classes/ia.core.smarty.php (seems modified).
  5. Vasily_B.

    Vasily_B. Project Manager

    Please ignore these error:
    core smarty - I would recommend to check the changes please compare 2.3.2 default file and the default one you currently have. You can use any diff tool, like WinMerge for windows. If there are no changes - please upload 2.3.3 version over you current one.

    Let us know the results please. Thanks!
  6. ModsGuru

    ModsGuru New Member

    Hello, accept my congratulations on your version release. I was able to upgrade the version easily, and it seems upgrade went fine. I also saw the errors you mentioned but my custom package is working fine. Thanks for the better upgrade system, that makes the development much easier!
  7. Vasily_B.

    Vasily_B. Project Manager

    Thanks for the feedback :) We really try to make upgrades as easy as possible. That's the top notch priority task for us.
  8. smartpc

    smartpc New Member

    ERROR: The checksum is not equal: includes/classes/ia.core.smarty.php

    Its the copyright message in the file

    2.3.2 txt is //##copyright##

    instead of

    /******************************************************************************
    *
    * COMPANY: Intelliants LLC
    * PROJECT: Subrion Content Management System
    * VERSION: 2.3.3
    ******************************************************************************/
  9. Vasily_B.

    Vasily_B. Project Manager

    Ohh, you can reupload it then, I suppose you've done that :)

    We will recheck the file and make sure this version replaces file copyrights correctly. Thanks for your input.
  10. Khairun

    Khairun New Member

    <in is still in version 2.3.1 and I tried to do you upgrade here...
    but I didnt get this trough.

    Then go to admin panel of your website. You will see a notice there to upgrade your version.

    I dont see any notice on the admin panel..
  11. wazza

    wazza Member

    You will need to do the 2.3.2 upgrade first

    Regards,
    Quentin
  12. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    Please follow the announcements in the forums. Quentin is right, you need to make updates consequently, 2.3.1 should be updated to 2.3.2 and then to 2.3.3
    Otherwise the system will not work!
  13. smnetworks

    smnetworks New Member

    I'm in the process of moving from 2.3.1 to the most current version. I started with 2.3.2...and now 2.3.3. This is the most recent error:

    "Unable to download the patch file." from http://www.nutrientcor.com/health-news
  14. Vasily_B.

    Vasily_B. Project Manager

    Our website was unavailable few minutes ago as we rebooted our server.

    Now I see the following:
    Please confirm if you still have the issue.

    Thanks!
  15. smnetworks

    smnetworks New Member

    I was able to update this through the:
    Admin Panel>Manage Database>SQL Management

    vs. the Upgrade Wizard.
  16. Vasily_B.

    Vasily_B. Project Manager

    Ahh, ok. It's great you've managed to upgrade, I hope next update will work for you.

Share This Page