Subrion CMS 2.3.4 has been released!

Discussion in 'Announcements' started by Vasily B., Feb 8, 2013.

  1. Vasily_B.

    Vasily_B. Project Manager

    Greetings,

    We are happy to announce the release of Subrion CMS 2.3.4! Here is the changelog:

    You can see the full details here - 2.3.4 - Subrion CMS

    Upgrade is available through admin panel! Don't forget to make backup of your files and database!
  2. mktg

    mktg New Member

    The upgrade from inside the Admin panel will just overwrite my customized files. The previous upgrades upto 2.3.3 had patch files available. Is a similar patch zipfile available for this new version?
  3. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    No it will not replace the modified files. It checks for hash and the files will be overwritten in case the hash is equal.

    You can get the new version files by downloading the core version.
  4. CarlosSpain

    CarlosSpain New Member

    Hello Vasily

    I just install the update to 2.3.4 and now I have a blank page. I can not access my page, nor the administrator panel. Help, please.
  5. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    Please apply backup. Did you submit a ticket? AFAIK you have modified version, and I'm not sure if you had 2.3.3

    Enable debug or check the error_log to see the log.
  6. CarlosSpain

    CarlosSpain New Member

    I have a modified version of 2.3.3. This means that I can't upgrade to 2.3.4?
  7. Greg

    Greg Super Moderator

    Well I didn't break anything. :cool:
    Upgrade worked great. Simple.
    Only thing I got was an error at the end:

    "The checksum is not equal — file md5() hash checksum does not match the default one that comes with Subrion software. It's possible this file was modified on your server."
  8. mktg

    mktg New Member

    I am getting "ERROR: File is non-writable" on all unmodified files. My installation has 777 permissions only on these folders: /tmp /uploads /includes

    Do I have to 777 all folders & sub-folders for this upgrade process to work?

    An additional problem is that I am getting "ERROR: The checksum is not equal" on files which I have not modified
    Last edited: Feb 8, 2013
  9. Greg

    Greg Super Moderator

    I believe that you should also chmod 777 backup/
  10. Miri

    Miri Guest

    please tell me the correct procedure to update it!?
    thanks
  11. smartpc

    smartpc New Member

    All went fine too, had same read out under Legend as Greg but no errors in log

    "The checksum is not equal — file md5() hash checksum does not match the default one that comes with Subrion software. It's possible this file was modified on your server."

    Oh white pages on directory package, its not compatible with 2.3.4 yet? (its the categories - blank page)


    Fatmir..........if your running 2.3.3 log into admin panel at the top of first screen you should see link say upgrade available - click link follow instructions remember, modified files wont be touched, you can alter by hand later.
    Last edited: Feb 9, 2013
  12. Vasily_B.

    Vasily_B. Project Manager

    Hi Guys,

    It seems the legend on bottom is non obvious, there are some guys who think it's an error report though it is intended to be a legend that explains the errors in details. Seems to be quite confusing..

    Here is how upgrade process works:

    1. The system downloads patch
    2. Unpacks it
    3. Then it compares hash sum for the files, that should be updated. If you modified some files they will not be overwritten instead you can see the notice about the modified file - PLEASE CAREFULLY READ THE INSTALLATION LOG!!!! as it explains what's wrong in case you have any problems.
    4. If files is non modified the system will replace the files, if not - get back to the log
    and merge the changes manually!

    P.S. modified version updates - please be careful, the upgrade process is just at its first stage and it does not do any magic yet - if you have modified files you'll need to merge them manually in case you perform upgrade!
  13. Exitilus

    Exitilus New Member

    For those truely in a bind after the upgrade and they are getting the "white screen". If you look at the upgrade log in the TMP folder. It will tell you what files were not updated. Download the full core for the newest version and manually upload those files.

    That fixed it for me :)
  14. Vasily_B.

    Vasily_B. Project Manager

    Thanks for sharing your experience. Yes, you will need to reupload the files manually in case you see the blank screen!
  15. graphixzonne

    graphixzonne New Member

    Hi
    I did the upgrade to version 2.3.0 to 2.3.1 to 2.3.2 to 2.3.3
    and now I can not do the next upgrade 2.3.4,
    I get the following message " {upgrade_available}"
    [​IMG]
    and not give me the link to upgrade to the next version...
    that's what I'm doing wrong? can assist me to update last version?
    thanks

    Attached Files:

    Last edited: Feb 24, 2013
  16. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    The link is easy. Simply open yourdomain.com/install/ in your browser and you'll find yourself in the upgrade area.

    Let us know if you have any problems.

    P.S. We highly recommend to make backup after every successful upgrade.
  17. graphixzonne

    graphixzonne New Member

    Hi,
    I did what you indicate and show me a message bar
    that says "overall progress", and other message that shows "Incorrect version specified upgrade." and will not let me do anything else, I click on the refresh button and it shows me the same
  18. Vasily_B.

    Vasily_B. Project Manager

    Hi,

    We've just pushed the upgrade to 2.3.7 version. You should not have any issues now.

    Thanks!

Share This Page