Subrion CMS 3.0.2 is released!

Discussion in 'Announcements' started by Vasily B., Oct 15, 2013.

  1. Vasily_B.

    Vasily_B. Project Manager

    Greetings,

    Meet another update of our content management system - 3.0.2. Here is the changelog:

    Bug #714: Loop redirect when trying to install to several server configurations
    Bug #850: Package cannot be created without adminblocks tags
    Bug #874: Adapt package index page
    Bug #927: Review design for all fields types on frontend
    Bug #979: Dropping cache on Packages page causes error.
    Bug #980: Can not fully clear cache folder
    Bug #988: Backend: Unable to remove images if assigned to the field of type Single Image Upload
    Bug #990: Edit block does not work for JS blocks
    Bug #994: Adding fields to groups odd behaviour
    Bug #996: underscore.min.js not found
    Bug #997: Incorrect dimensions for image field
    Bug #999: Set greater width for grid numberer
    Bug #1001: Pages filter does not work correctly
    Bug #1004: Creating new field: errors after wrong filling of inputs
    Bug #1005: Australia timezone is not listed
    Bug #1006: Database export: doesn't work / works incorrectly
    Bug #1007: Incorrect links to Manage / Config pages for a plugin
    Bug #1008: Incorrect log formation for packages
    Feature #578: To make capable to show custom messages at 403 Forbidden error
    Feature #703: Implement forced files update
    Feature #758: Configurable signatures for e-mail templates
    Feature #981: Add timestamp to blogposts and newsposts
    Feature #982: Improve installer
    Feature #987: Use notifFloatBox for grid update​

    Details could be found in our Issue Tracker.

    Update is available through the automatic update.

    Ask in case you have any questions.
  2. Greg

    Greg Super Moderator

    After update I get this:
    Is this a problem?
  3. Vasily_B.

    Vasily_B. Project Manager

    Yes, this may happen for a few files. Do you remember what files were reported as modified?

    Thanks!
  4. Greg

    Greg Super Moderator

    I don't think it mentioned a particular file. I haven't modified any files.
  5. Vasily_B.

    Vasily_B. Project Manager

    So, what version do you have now? You can see it in the admin dashboard.

    BTW, if you are 100% sure you didn't modify any files you can use the option - FORCE files upload during upgrade. The upgrade script will ignore hashsum checking and overwrite all your files.
  6. Greg

    Greg Super Moderator

    v3.0.2.20
    I didn't modify any files. I can just do a fresh install if that's going to cause an issue.
  7. Greg

    Greg Super Moderator

    I did modify the phone field (removed it) on the contact us plugin.
  8. Vasily_B.

    Vasily_B. Project Manager

    Yep, the version is correct. Contacts should not affect the core files as we only check core files hashsum.

    We implemented mandatory automatic patches for the versions. Example. You have 3.0.2 version and it has some minor issues with the admin dashboard files. We can release a mini-upgrade patch that fixes these issues. The patch is applied automatically and your version is changed. It won't change modified files.
    Of course you can disable this functionality if needed. Anyhow, now I recommend to keep it turned on.
  9. Greg

    Greg Super Moderator

    Thanks. So I'm OK? No need to be concerned with that warning?
    Have a good day.
  10. Vasily_B.

    Vasily_B. Project Manager

    Yes, I think the version has been updated. Not sure about the message. Anyhow, let's wait for the next release so you could turn on the force files upload option and your files will become updated.
  11. smartpc

    smartpc New Member

    Hi Simon,

    I got the errors:
    ERROR: Unable to remove the directory: js/jquery/plugins/adgallery
    ERROR: Unable to remove the directory: js/jquery/plugins/colorbox
    ERROR: Unable to remove the directory: js/jquery/plugins/ias
    ERROR: Unable to remove the directory: js/jquery/plugins/popeye
    ERROR: The checksum is not equal: install/classes/ia.patch.applier.php (seems modified). Skipped
    ERROR: The checksum is not equal: install/modules/module.install.php (seems modified). Skipped
    ERROR: The checksum is not equal: templates/skeleton/css/iabootstrap.css (seems modified). Skipped
    ERROR: The checksum is not equal: templates/skeleton/layout.tpl (seems modified). Skipped

    I did go near ia bootstrap and maybe layout, but not anything else
  12. Vasily_B.

    Vasily_B. Project Manager

    Hi guys,

    Please ignore them - directory removal worked fine, it only produces error on some specific servers. No worries about template/& install notices also. There is some kind of auto update, and it upgrades some files.
    Nothing to worry about. I would only recommend to keep an eye on core files notices.

    Thanks for the report.

Share This Page